Support Ticket System Unavailable
Incident Report for Sisense Service Page
Resolved
The support portal is now operational and all functionality has been restored.
Posted Jul 20, 2023 - 19:40 PDT
Investigating
The backend service that powers Sisense's ticket portal is currently down. In the interim, new tickets can be submitted to the Sisense Support Team via email at support@sisense.com.
Posted Jul 20, 2023 - 12:19 PDT
This incident affected: Sisense Managed Service.